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About the Piece

In SGLC, laptop musicians use the LOLC textual performance interface to create,
share, borrow, and transform musical motives based on a collection of pre-
composed score fragments. As the laptop players create these motives, they are
displayed on computer monitors as real-time music notation that instrumental
musicians must sight-read during the performance. This unusual setup encourages
all of the musicians to share their musical ideas with each other, developing an
improvisational conversation over time. SGLC, as well as the LOLC software
environment it employs, is supported by a grant from the National Science
Foundation as part of a larger research project on musical improvisation in
performance and education (NSF CreativelT #0855758). It was written for Sonic
Generator, the contemporary music ensemble in residence at Georgia Tech.

Jason Freeman, Akito Van Troyer, Andrew Colella, Sang Won Lee, and Shannon Yao
developed the LOLC software it employs; Andrew and Sang Won in particular
helped develop the music notation components of it that were created specifically
for SGLC.

Duration
Duration varies but is typically about 10 minutes (250 measures).
Instrumentation

SGLC can be performed by any number of musicians, provided there are equal
numbers of laptop and instrumental musicians. The instrumental musicians can
play any pitched, monophonic instrument with standard Western chromatic tuning.
There is no conductor.

For Sonic Generator, the instrumentation is flute, bass clarinet, violin, cello, and four
laptop musicians.



Technical requirements

Each laptop musician in the ensemble is paired with one of the instrumental
musicians. Each pair shares a computer workstation consisting of a Mac or Windows
laptop and an external monitor. Since there is no electroacoustic sound in this piece
— the instrumental musicians play all of the music acoustically — there is no need
for speakers or any other audio equipment.

The following additional equipment is required:
e A wireless network router. The router need not be connected to the Internet.

* A Mac or Windows computer that acts as the server. This must be a separate
machine, not one of the laptops used by a performer.

* A projector.
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Performance Layout

All of the musicians should sit in a semicircle on stage, with the projection screen
behind them. Each laptop-instrument pair of musicians should sit next to each other
within the semicircle. The computer monitors should be placed in a comfortable
viewing location for the instrumental musicians; | recommend using an adjustable-
height multimedia or speaker stand such as a Da-Lite Project-o-Stand 203 for this
purpose. The laptop musicians should keep the laptops on their laps or should use a
similar adjustable height multimedia stand as those used for the monitors. The
laptop musicians should be able to see their external display from where they are
sitting.
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Installing the LOLC Software

All laptop musicians in the ensemble must run the LOLC Client software on their
laptops. The server computer must run the LOLC Server software.

To install and run this software, follow these steps:

Everyone must install a JMSL license (see instructions below).
Download the LOLC software from http://www.jasonfreeman.net/lolc/.
Double-click the download to decompress it.

Double-click the client or server application files to launch. It may take a
minute for the software to launch; please be patient.
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Installing the JMSL License

LOLC was developed using Nick Didkovsky’s Java Music Specification Language
(JMSL) and Phil Burk’s JSyn audio architecture. You must install a license for JMSL
on your laptop in order for LOLC to function properly.

To install the license, follow these steps:

1. Register for a free 30-day JMSL license at
http://www.algomusic.com/algomusiclicense /request_jmsl demo license.html

2. Download the JMSL software.

3. Inthe JMSL folder, double-click the JMSL_License_installer.jar file.

4. Drag the JMSL.ic file you receive via e-mail onto the gray area to install the
license.

If you wish to continue using LOLC after 30 days, please contact us at
http://www.jasonfreeman.net/contact/ to get a free, non-expiring license to
continue using JMSL with LOLC.

We apologize for the hassle of installing this license and are currently working with
Algomusic on a new solution that will eliminate these additional installation steps.

Configuration parameters for SGLC
For the LOLC Client software:

1. Make sure that your system settings do not mirror displays. The laptop
display and external monitor must function as two independent displays.

2. Ignore the audio parameters in the startup dialog box. These are not used for
SGLC.

3. Once startup is complete, go to Window->Music Notation to launch the real-
time music notation viewer.

4. Drag the LOLC windows so that the music notation window appears on the
external display and the main window appears on the laptop display.

5. Go to Window->Transpose. Select the clef most appropriate for the
instrument that will be reading notation from your external display. If itis a



transposing instrument, also select the appropriate key signature
transposition. Do not select any chromatic transposition options; this is not
used in SGLC. Select the MIDI note numbers that represent the low and high
notes (written pitch) that the corresponding player is able and willing to play
in SGLC.

6. (Optional) Set up the click track. Go to Window->Transpose. Default sound
files for the downbeat (left box) and upbeat (right box) are provided. You can
change these by typing in the name of any sound file in the LOLC sound
folder (lib/sound inside of the main LOLC folder on Windows; or right-click
the application to Show Package Contents->Contents/Resources/lib/sound
on Mac). Then click the checkbox to start the click track. The click track is
played out of the sound device and channel configured for “main playback” in
the startup window of the LOLC client. Typically, you would play the click
track out of the built-in audio on your laptop and plug headphones into your
laptop’s headphone jack.

For the LOLC Server software:

1. If the computer has more than one display, make sure that the system
settings do mirror displays. Both displays should show the same thing.

2. In the startup dialog box, set tempo to 84 bpm, beats per measure to 3, and
beat unit to half note.

3. Once the server has launched, hit the space bar to toggle the visualization to
full-screen mode.

Learning LOLC

The best way to learn LOLC is to read through the LOLC tutorial and try out the
examples it includes. The LOLC tutorial is included with the LOLC client. After
launching LOLC, choose Help->Tutorial from the menu.

The application also includes a quick command reference (Help->Reference).

Note that the tutorial and reference cover working with both scores and with audio
files. SGLC only uses the score / notation features of LOLC and does not use any
audio files.

Configuring LOLC
Individual Practice
When using LOLC by yourself, launch both the server and the client on your laptop:

1. Launch the LOLC server.
2. Launch the LOLC client.
3. Hit connect in the client’s network dialog box, using the default settings.

Network Configuration



When using LOLC in an ensemble, follow these steps:

1. Connect all computers (client and server) to your local wireless router.

2. Note the IP address of the server computer. The IP address is listed in System

Preferences->Network on Macs.

Launch the LOLC server on the server computer.

Launch the LOLC client on each of the musicians’ computers.

In the network dialog box in each LOLC client, enter the server’s IP address

(see step 2), a username of your choice, and a unique identifying color for

your user. Then hit connect.

6. Verify the configuration by checking the LOLC server visualization. Once all
usernames are represented by circles, configuration is complete.
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If an LOLC client cannot connect to the server, try these troubleshooting tips:

= Make sure that the client machine is running on the same wireless
network as the server.

= Make sure that you entered the IP address of the server correctly.

= Make sure that you are running the same version of LOLC as the server.
LOLC client Options and Features
Chat Pane

The chat pane is the main interface through which to interact with LOLC in
performance. You can type in LOLC pattern definitions and scheduling operations in
the bottom-right text field. To execute them, hit enter. To enter a chat message that
the other musicians can read, hit shift-enter.

The chat pane includes several features to help you type faster. Clicking on any
previous message in the chat view will copy it into the text field so you can quickly
edit and re-execute it. Pressing the up arrow will cycle through a history of the
previous code you have typed. And as you type, LOLC auto-completes your words:
just click on a suggested word or hit tab to accept the default suggestion.

Pattern Library Pane

The pattern library helps you to understand the patterns created within the
ensemble and to borrow and transform material created by others.

The Pattern List shows all currently-defined patterns. The colors of blocks indicate
the score files they play, their brightness indicates their dynamic, the lengths of the
blocks indicate the rhythmic duration of each event within the pattern, and their
height indicates their pitch. Since this list can quickly become long, numerous
options on the “Organize” tab help you to sort and filter the list of variables to find
specific patterns based on their author, the scores they use, when they were created,
and other criteria.



The “Currently Playing” tab helps you track the music playing within the ensemble,
showing which specific patterns are currently playing.

The “File names in use” tab explains the color coding of patterns in the pattern list,
linking colors to the sounds they represent.

Console Pane

The console displays status and error messages. Pay special attention to the console
for syntax errors when you execute pattern definition and scheduling expressions.

Scores

All music in SGLC is built upon a pre-composed collection of 53 fragments of music
notation. The Appendix includes each notated fragment. In short, their contents are:

* a2,a3, a4, a5, a6; bb2 through bb6; c2 through c7; d2 through d6; eb2
through eb6; f2 through f6; and g2 through g6: These are all single three-
measure long held notes on the indicated pitch; c4 is concert middle C.

* x1,x2, x3,x4: These are two-measure melodic motives.

* vyl,y2,y3,y4,y5, y6: These are graphic notations, each one measure long,
that indicate a general melodic contour to guide improvisation.

* z1,z2,73,74, 25, 76: These are text instructions, each one measure long, to
guide improvisation.

* rest: A measure of rest.

Music Notation Window

The music notation window is largely self-explanatory. To assist instrumental
musicians in keeping track of the current beat and measure, a cursor indicates
measure position. Rests also fill empty measures to indicate the current measure.

Musicians should always read the top-most staff system. When they reach the end of
that system, it will disappear and the next system will move into the top-most
position. This maximizes the amount of music musicians can read ahead and
eliminates awkward page turns.

LOLC server Options and Features
Visualization

The main window of the server shows a visualization of LOLC performers, status,
code, collaboration, and chat messages. Please project this screen behind the
musicians so that audience members can see it during performance.

To show the visualization in full-screen mode, hit the space bar.

In performance, you should configure LOLC so that the placement of each performer
on screen corresponds to her physical location on stage. To do so, edit



“stageLayout.xml” inside of the main LOLC folder on Windows (or right-click the
application to Show Package Contents->Contents/Resources/lib/code on Mac).
Follow the example file to create an entry for each performer that identifies their
user id and x/y placement on screen.

A single circle on the projection represents each instrument/laptop musician pair.
Choose a user name that clearly reflects the people that circle represents, such as
the name of the instrument (“cello,” “flute”) or the names of both laptop and
instrumental players (“Joe and Agnes”).

Console

The console shows server status, error messages, and network connection activities
(e.g. client connects and disconnects).

Menu

“Reload All Variables” will clear all patterns out of the server and reload the default
variables from the startup file.

“Dump actions to file” will log all code and chat messages to a text file. Select it once
to begin recording and a second time to stop recording. The file is stored in
lib/stash/.

We recommend that you edit the LOLC startup file (in lib/code/startup.lolc) and
remove any “.wav” file definitions (keep the “.xml” definitions). This will improve
efficiency of the server and clients in performance.

Preparing a Performance of SGLC

SGLC can frustrate common rehearsal and practice strategies since the music
notation itself is different in each performance and the structure of the work
mandates substantial improvisation by both laptop and instrumental musicians.

Here are some quick tips for preparing:

* Laptop musicians should dedicate substantial time to individual practice in
advance of group rehearsals. Read the tutorials, become familiar with LOLC,
and commit the core LOLC commands and syntax to memory.

* Instrumental musicians should dedicate individual practice time to the
musical fragments in the Appendix. While these fragments represent a small
fraction of the music notation that will appear in any given performance, they
are the basis for all notation that will be generated, and so familiarity with
these fragments will facilitate sight-reading of all music in performance.

e Each laptop/instrumental musician pair should practice as a pair at least
once before the first ensemble rehearsal, getting accustomed to the



equipment setup, sight-reading, pacing, and the components of the formal
structure.

* Ininitial full-ensemble rehearsals, one of the laptop musicians should act as a
conductor, controlling pacing and detailed movement through the work’s
formal structure via chat messages. This role may be maintained for
performances or the ensemble can move towards a more distributed mode of
control.

SGLC Structure

While much of SGLC is improvised, there is a general formal structure that guides
that improvisation in performance. This section describes the structure and should
be used as a guide in performance and rehearsal.

Some important notes and explanations:

* The entire performance should last approximately 250 measures.

* Always borrow and transform the patterns created by others, using whatever
operations are allowed within the current section.

e Itisup toyou to decide how to coordinate movement from section to section,
and whether (and when) transitions should be sudden or gradual.

* The example code fragments are deliberately simple; do not feel restricted to
using similarly simple operations and expressions in your performance.

* None of these guidelines are strict, and any specifics of the structure can be
ignored or changed for good musical reasons, either in the moment of a
performance or as planned through rehearsal.

Description Example Code Fragments
Long tone clusters piay gzl

Play G4, A4, Bb4, and/or C5. Only “play” is glzz b

allowed. play c5

(These are the only four choices.)

Add operations c5ff : amplify(c5, 3)
: . g4loudsoft : g4[w.ff, w.pp]
+ 8.
Above use anyoperat10nsyouw1§h (e.g adstartlate : cat(rest[h], ad)
cat, amplify, bracket syntax, dynamics, c5beats : c¢5[q,q.n, h.p]
rests, and loops). play adstartlate

loop cat(c5beats, rest, rest) ~4

All pitches c2ff : amplify(c2, 3)
Above + use any pitches, not just G4, A4, géloudsoft : g6[w.ff, w.pp]
Bb4, and C5.
Melodic Motives Elay x; ]

oop x2 ~
Play, loop, .and/or .cat x1, x2, x3, and x4 longmelody : cat(xl, x3, x2)
only. Nothing else is allowed. loop longmelody ~4

Add operations highxl : transpose(xl, 12)




Above + use any operations you wish (e.g. | shufflex2 : shuffle(x2)
: . bigmess: shuffle(cat(xl1,
cat, amplify, bracket syntax, dynamics, transpose (x2, -12), amplify(x3,
rests, and loops). 2))
play highxl
loop bigmess ~8

(plus above examples)

Anything Goes sparser : cat(x2, d5, x1, eb4d)
. bursts : cat(xl[h], d5[w],
Above + add in long tones, contours (y trunc(xl, 8), c5)
patterns), text (z patterns), and all loop bursts ~4
operations. play sparser
play vyl

ylbeg : yllq,q,9,q]
ylrand : shuffle(yl)
yx : alternate(yl,y2)

loop yx ~16
play zl1
loop z2 -8

switching : cat(xl, yl, zl)
loop switching ~4

(plus above examples)

Endin kill * @ 250
The ending may be a subito stop at the end
of a long buildup, or it may be a slow and
gradual process.

Getting Help and Getting in Touch

Please do not hesitate to contact me with technical questions, bug reports, or other
issues. I would also love to hear about your experiences with SGLC.

I can be reached via:
http://www.jasonfreeman.net/contact/
Most importantly, have fun with SGLC!
Jason Freeman

Atlanta, Georgia

July 21, 2011
rev. January 31, 2013




Appendix: Score Fragments

All fragments are played at half
note at 84 bpm.

The long tone fragments all contain
three measures of a single note, with a
quarter note rest at the end of the last
measure. Musicians need not be
limited to using these pitches in
performance — they can notate any
pitch with the transpose() operation
— but these are intended to be the
dominant pitches used throughout.
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The six y patterns represent melodic
contours to guide improvisation. They
need not be construed solely as a
series of discrete notes at regular time
intervals; their interpretation can and
should be much more flexible than
that. Anything from glissandi to
irregular rhythmic patterns and
pointilism are possible so long as the
general contour remains. Laptop
musicians may use chat messages to
clarify the intended interpretation of a
particular contour or series of
contours during a performance. (The
instrumental musicians see all chat
messages on their display.) The
contours themselves can be modified
using all the standard LOLC
transformations.
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The six z patterns are broad textual
guidelines for improvisation: to
borrow (i.e. literally recreate) a
pattern the musician herself has
already played during the
performance (z1); to borrow a pattern
another musician has already played
(z2); to transform (i.e. borrow and
somehow change) a pattern the
musician herself has already played
(z3); to transform a pattern another
musician has already played (z4); to
merge multiple patterns played by
other musicians into a single musical
idea (z5); and to play anything at all
(z6). The angular noteheads are a
rendering artifact of the LOLC
notation environment and should be
ignored.
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Z 5 . merge others
.
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Z 6 . play anything



